Slackwarearm-14.2 ChangeLog (2018-02-20)

Tue Feb 20 08:08:08 UTC 2018


Please note that the 'gcc-gnat' package has not been upgraded. This is because
it seems to build for a target host >armv5, despite being configured otherwise.
I've spent a while looking in to it, but haven't been able to resolve it yet.
However, the previous gcc-5.3.1 gnat didn't work on armv5 either for the same
reason. If anybody feels like looking at it, please ask on the LQ forum and I
can give you what I have found so far.

The GCC update does not contain any patches to mitigate any Spectre variants on
ARM. I have not seen any ARM patches materialise yet, but I'll keep an eye out
for those.
  • news/2018/02/20/slackwarearm-14.2-changelog.txt
  • Last modified: 20 months ago
  • by Giuseppe Di Terlizzi