Slackwarearm-current ChangeLog (2021-04-06)

Tue Apr 06 08:08:08 UTC 2021

installdocs/*: Updated.
In preparation for Slackware AArch64:
The 'boardsupport' directory has been renamed 'platform'.
The sub directory 'u-boot' has been renamed 'bootware'.
Updated asset URLs references accordingly.
You do not need to change anything - these changes affect the documented
installation process only.

Important note: glibc now requires a minimum of Linux 5.10.
Ordinarily the minimum Kernel requirement set to support earlier Linux
Kernels. However, as with the Slackware AArch64, this port of Slackware
(hardware floating point, 32-bit armv7) has never had a stable release, so
there's no requirement to support upgrades from any previous version of the
OS so it makes sense to set to the latest running Kernel.
If you are running a local build of the Kernel on Slackware ARM, you'll need
to ensure that you upgrade the Kernel if necessary before applying this glibc
update.
  • a/aaa_glibc-solibs-2.33-arm-2.txz
  • d/Cython-0.29.22-arm-2.txz
    Recompiled to fix building some programs that use Cython. It's possible
    that this was due to an ABI bug that shipped in Python-3.9.3, but we'll
    rebuild to be on the safe side.
    Thanks to PiterPunk who noticed this issue on 32-bit.
  • kde/calligra-3.2.1-arm-9.txz
    Recompiled against poppler-21.04.0.
  • kde/cantor-20.12.3-arm-3.txz
    Recompiled against poppler-21.04.0.
  • kde/kfilemetadata-5.80.0-arm-2.txz
    Recompiled against poppler-21.04.0.
  • kde/kile-2.9.93-arm-8.txz
    Recompiled against poppler-21.04.0.
  • kde/kitinerary-20.12.3-arm-3.txz
    Recompiled against poppler-21.04.0.
  • kde/krita-4.4.3-arm-2.txz
    Recompiled against poppler-21.04.0.
  • kde/okular-20.12.3-arm-2.txz
    Recompiled against poppler-21.04.0.
  • l/glibc-2.33-arm-2.txz
    Applied upstream patch to fix a performance regression:
    [PATCH] linux: Normalize and return timeout on select (BZ #27651)
    Thanks to Fulalas and Adhemerval Zanella.
    Important note: Now requires a minimum of Linux Kernel version 5.10.
  • l/glibc-i18n-2.33-arm-2.txz
  • l/glibc-profile-2.33-arm-2.txz
  • n/cyrus-sasl-2.1.27-arm-8.txz
    Fixed broken formatting within saslauthd(8).
    Thanks to MisterL on LQ for the report.
  • n/network-scripts-15.0-noarch-12.txz
    netconfig: remove (broken) checks on hostname/domainname validity.
  • a/file-5.40-arm-1.txz
  • a/hwdata-0.346-arm-1.txz
  • a/kernel-firmware-20210405_af1ca28-noarch-1.txz
  • ap/ghostscript-9.54.0-arm-1.txz
  • ap/inxi-20210329_a539c8fd-noarch-1.txz
  • ap/sqlite-3.35.4-arm-1.txz
  • d/help2man-1.48.3-arm-1.txz
  • d/python3-3.9.4-arm-1.txz
    This update reverts a change that introduced an unintentional ABI
    incompatibility making some C extensions built with Python 3.9.0 - 3.9.2
    crash with Python 3.9.3 on 32-bit systems.
  • d/ruby-3.0.1-arm-1.txz
    This release includes a security fix:
    XML round-trip vulnerability in REXML.
    For more information, see:
    https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2021-28965
    (* Security fix *)
  • l/at-spi2-core-2.40.0-arm-1.txz
  • l/cryfs-0.10.3-arm-1.txz
  • l/dbus-glib-0.112-arm-1.txz
  • l/dconf-0.40.0-arm-1.txz
  • l/dconf-editor-3.38.3-arm-1.txz
  • l/gcr-3.40.0-arm-1.txz
  • l/gdk-pixbuf2-2.42.4-arm-1.txz
  • l/gjs-1.68.0-arm-1.txz
  • l/glib-networking-2.68.0-arm-1.txz
  • l/glib2-2.68.0-arm-1.txz
  • l/gobject-introspection-1.68.0-arm-1.txz
  • l/gtk+3-3.24.28-arm-1.txz
  • l/gvfs-1.48.0-arm-1.txz
  • l/imagemagick-7.0.11_6-arm-1.txz
  • l/libqalculate-3.18.0-arm-1.txz
  • l/netpbm-10.94.01-arm-1.txz
  • l/opencv-4.5.2-arm-1.txz
  • l/poppler-21.04.0-arm-1.txz
    Shared library .so-version bump.
  • l/pygobject3-3.40.1-arm-1.txz
  • l/python-docutils-0.17-arm-1.txz
  • l/python-pillow-8.2.0-arm-1.txz
  • l/vte-0.64.0-arm-1.txz
  • n/bluez-5.58-arm-1.txz
  • n/curl-7.76.0-arm-1.txz
    This update fixes security issues:
    Authentication Bypass by Spoofing.
    Exposure of Private Personal Information to an Unauthorized Actor.
    For more information, see:
    https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2021-22890
    https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2021-22876
    (* Security fix *)
  • x/libXres-1.2.1-arm-1.txz
  • x/libva-utils-2.11.1-arm-1.txz
  • xap/gimp-2.10.24-arm-1.txz
  • xap/pidgin-2.14.2-arm-1.txz
  • xap/xscreensaver-6.00-arm-1.txz
  • xfce/mousepad-0.5.4-arm-1.txz
  • news/2021/04/06/slackwarearm-current-changelog.txt
  • Last modified: 12 days ago
  • by Giuseppe Di Terlizzi