Slackwarearm-current ChangeLog (2021-10-08)

Fri Oct 08 08:08:08 UTC 2021

  • a/hwdata-0.352-arm-1.txz
  • ap/nano-5.9-arm-1.txz
  • d/mercurial-5.9.2-arm-1.txz
  • l/libgnt-2.14.3-arm-1.txz
  • l/librsvg-2.52.1-arm-1.txz
  • l/mozjs78-78.15.0esr-arm-1.txz
  • l/netpbm-10.96.01-arm-1.txz
  • l/polkit-0.120-arm-1.txz
  • n/epic5-2.1.6-arm-1.txz
  • n/gnupg2-2.2.32-arm-1.txz
  • n/httpd-2.4.51-arm-1.txz
    SECURITY: CVE-2021-42013: Path Traversal and Remote Code
    Execution in Apache HTTP Server 2.4.49 and 2.4.50 (incomplete
    fix of CVE-2021-41773) (cve.mitre.org)
    It was found that the fix for CVE-2021-41773 in Apache HTTP
    Server 2.4.50 was insufficient. An attacker could use a path
    traversal attack to map URLs to files outside the directories
    configured by Alias-like directives.
    If files outside of these directories are not protected by the
    usual default configuration “require all denied”, these requests
    can succeed. If CGI scripts are also enabled for these aliased
    pathes, this could allow for remote code execution.
    This issue only affects Apache 2.4.49 and Apache 2.4.50 and not
    earlier versions.
    Credits: Reported by Juan Escobar from Dreamlab Technologies,
    Fernando MuA+-oz from NULL Life CTF Team, and Shungo Kumasaka
    For more information, see:
    https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2021-42013
    (* Security fix *)
  • n/openvpn-2.5.4-arm-1.txz
  • x/xkeyboard-config-2.34-arm-1.txz
  • xap/xpaint-3.1.4-arm-1.txz
  • kde/audiocd-kio-21.08.1-arm-2.txz
  • kde/kio-5.86.0-arm-3.txz
    Allow changing panel launcher icons. Thanks to RadicalDreamer
    and ctrlaltca.
  • xap/gftp-2.7.0b-arm-3.txz
    Removed broken icon symlink. Thanks to marav.
  • news/2021/10/08/slackwarearm-current-changelog.txt
  • Last modified: 7 weeks ago
  • by Giuseppe Di Terlizzi