Slackwarearm-14.2 ChangeLog (2016-03-28)

Mon Mar 28 03:06:12 UTC 2016


The mini root filesystem for -current has also been updated:
ftp://ftp.arm.slackware.com/slackwarearm/slackwarearm-devtools/minirootfs/
Thanks to Johann Wilhelm for bringing my attention to a couple of bugs in the
mini root build script.
  • a/aaa_elflibs-14.2-arm-8.txz
  • a/etc-14.2-arm-7.txz
    Added polkitd user (UID 87) and group (GID 87).
  • a/pkgtools-14.2-noarch-4.txz
    In installpkg's terse mode, make some dots connecting the description to the
    uncompressed package size.
  • a/utempter-1.1.6-arm-2.txz
  • kde/calligra-2.9.11-arm-2.txz
    Recompiled against poppler-0.42.0.
  • kde/kde-workspace-4.11.22-arm-3.txz
    Recompiled against shared library from pciutils-3.4.1.
  • kde/kdelibs-4.14.18-arm-2.txz
  • kde/ktouch-4.14.3-arm-3.txz
    Patched to fix performance issues. Thanks to Andrzej Telszewski.
  • kde/lskat-4.14.3-arm-3.txz
    Fixed a typo in slack-desc.
  • l/libzip-1.0.1-arm-2.txz
    Fixed manpage symlinks. Thanks to elyk.
  • n/NetworkManager-1.0.10-arm-3.txz
    Patched rc.networkmanager to only attempt to kill wpa_supplicant on shutdown
    using the first .pid found in /var/run or /run. Otherwise if those
    directories are symlinked or bind mounted together there will be a race
    condition that may result in an error message.
    Thanks to allend for the original suggestion that wpa_supplicant should be
    killed. However, Pat is still not certain that rc.networkmanager should be
    messing with wpa_supplicant. What about cases where NetworkManager might be
    configured to *not* manage the wireless interfaces at all?
    Luckily, there is rarely any reason for stopping NetworkManager (outside of
    shutdown or reboot), or for restarting it.
  • tcl/tk-8.6.5-arm-2.txz
  • xap/hexchat-2.12.0-arm-2.txz
    Recompiled against shared library from pciutils-3.4.1.
  • xfce/tumbler-0.1.31-arm-5.txz
    Recompiled against poppler-0.42.0.
  • xfce/xfce4-power-manager-1.4.4-arm-4.txz
    Removed dead symlinks in documentation. Thanks to elyk.
  • extra/wicd/wicd-1.7.4-arm-3.txz
    Fix wicd-curses crash bugs. Thanks to foobaru, Tonus, and comet.berkeley.
  • isolinux/*
  • a/dbus-1.10.8-arm-1.txz
  • a/glibc-zoneinfo-2016c-arm-1.txz
  • a/kernel-firmware-20160326git-noarch-1.txz
  • a/lvm2-2.02.148-arm-1.txz
  • a/ntfs-3g-2016.2.22-arm-1.txz
    Shared library .so-version bump.
  • a/pciutils-3.4.1-arm-1.txz
    Use a shared libpci, not a static one. This fixes linking some programs as
    the static library won't pull in other recent dependencies such as libudev.
    Thanks to 55020.
  • ap/cups-filters-1.8.3-arm-1.txz
    Recompiled against poppler-0.42.0.
  • ap/ddrescue-1.21-arm-1.txz
  • ap/hplip-3.16.3-arm-1.txz
  • ap/man-pages-4.05-noarch-1.txz
  • ap/mc-4.8.16-arm-1.txz
  • ap/sudo-1.8.16-arm-1.txz
  • ap/zsh-5.2-arm-1.txz
  • d/cmake-3.5.1-arm-1.txz
  • d/git-2.7.4-arm-1.txz
    NOTE: Issuing this patch again since the bug reporter listed the
    wrong git version (2.7.1) as fixed. The vulnerability was actually
    patched in git-2.7.4.
    Fixed buffer overflows allowing server and client side remote code
    execution in all git versions before 2.7.4.
    For more information, see:
    http://seclists.org/oss-sec/2016/q1/645
    http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2016-2315
    http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2016-2324
    (* Security fix *)
  • l/dbus-python-1.2.4-arm-1.txz
  • l/harfbuzz-1.2.4-arm-1.txz
  • l/iso-codes-3.66-arm-1.txz
  • l/libevent-2.0.22-arm-1.txz
    Multiple integer overflows in the evbuffer API allow context-dependent
    attackers to cause a denial of service or possibly have other unspecified
    impact via “insanely large inputs” to the (1) evbuffer_add,
    (2) evbuffer_expand, or (3) bufferevent_write function, which triggers a
    heap-based buffer overflow or an infinite loop.
    For more information, see:
    http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2014-6272
    (* Security fix *)
  • l/libodfgen-0.1.6-arm-1.txz
    Thanks to Heinz Wiesinger.
  • l/librevenge-0.0.4-arm-1.txz
    Thanks to Heinz Wiesinger.
  • l/libsecret-0.18.5-arm-1.txz
  • l/libvisio-0.1.5-arm-1.txz
    Thanks to Heinz Wiesinger.
  • l/libwpd-0.10.1-arm-1.txz
    Thanks to Heinz Wiesinger.
  • l/polkit-0.113-arm-1.txz
    Polkit config format change: Uses “.rules” files rather than “.pkla”, and
    the rules files are JavaScript. Thanks to Robby Workman.
    Ensure that polkitd user (UID 87) and group (GID 87) exist.
    Ensure correct permissions on /etc/polkit-1/rules.d.
    Remove obsolete .pkla rules and /etc/polkit-1/localauthority directory.
    Don't build and install examples.
  • l/polkit-gnome-0.105-arm-1.txz
    Thanks to Robby Workman.
  • l/poppler-0.42.0-arm-1.txz
    Shared library .so-version bump.
  • l/taglib-1.10-arm-1.txz
    Thanks to Heinz Wiesinger.
  • l/urwid-1.0.3-arm-1.txz
    Switch to version 1.0.3, since wicd has problems with newer versions.
  • n/bluez-5.38-arm-1.txz
    Use reset=1 when loading the btusb module.
    Applied upstream patch to fix a crash when connecting to audio controllers.
    Thanks to gmgf.
  • n/curl-7.48.0-arm-1.txz
  • n/irssi-0.8.19-arm-1.txz
  • n/mtr-0.86-arm-1.txz
  • n/nmap-7.11-arm-1.txz
  • tcl/tcl-8.6.5-arm-1.txz
  • x/xkeyboard-config-2.17-arm-1.txz
  • xap/fvwm-2.6.6-arm-1.txz
  • extra/brltty/brltty-5.3.1-arm-1.txz
    Added upstream patch to prefer a blank if the same glyph is used for other
    characters. Added udev rules. Thanks to Didier Spaier.
  • news/2016/03/28/slackwarearm-14.2-changelog.txt
  • Last modified: 4 years ago
  • by Giuseppe Di Terlizzi