Differences

This shows you the differences between two versions of the page.

Link to this comparison view

Next revision
Previous revision
Last revision Both sides next revision
news:2014:12:23:slackware64-current-changelog [2015/03/10 01:12]
Giuseppe Di Terlizzi creata
news:2014:12:23:slackware64-current-changelog [2015/03/10 12:39]
Giuseppe Di Terlizzi
Line 15: Line 15:
   * [[slackware64.current>l/libusb-1.0.19-x86_64-1.txz]]   * [[slackware64.current>l/libusb-1.0.19-x86_64-1.txz]]
   * [[slackware64.current>l/libusb-compat-0.1.5-x86_64-1.txz]]   * [[slackware64.current>l/libusb-compat-0.1.5-x86_64-1.txz]]
-  * [[slackware64.current>n/ntp-4.2.8-x86_64-1.txz]] (Security fix) +  * [[slackware64.current>n/ntp-4.2.8-x86_64-1.txz]] \\   In addition to bug fixes and enhancements, this release fixes \\   several high-severity vulnerabilities discovered by Neel Mehta \\   and Stephen Roettger of the Google Security Team. \\   For more information, see: \\     https://www.kb.cert.org/vuls/id/852879 \\     http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2014-9293 \\     http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2014-9294 \\     http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2014-9295 \\     http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2014-9296 \\   (Security fix *
-  * [[slackware64.current>n/php-5.4.36-x86_64-1.txz]] (Security fix)+  * [[slackware64.current>n/php-5.4.36-x86_64-1.txz]] \\   This update fixes bugs and security issues. \\   #68545 (NULL pointer dereference in unserialize.c). \\   #68594 (Use after free vulnerability in unserialize()). (CVE-2014-8142) \\   #68283 (fileinfo: out-of-bounds read in elf note headers). (CVE-2014-3710) \\   For more information, see: \\     http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2014-3710 \\     http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2014-8142 \\   (* Security fix *)
   * [[slackware64.current>x/libdrm-2.4.58-x86_64-1.txz]]   * [[slackware64.current>x/libdrm-2.4.58-x86_64-1.txz]]
   * [[slackware64.current>x/mesa-10.3.5-x86_64-1.txz]]   * [[slackware64.current>x/mesa-10.3.5-x86_64-1.txz]]
Line 23: Line 23:
  
 ==== Added ==== ==== Added ====
-  * [[slackware64.current>x/libvdpau-0.9-x86_64-1.txz]]+  * [[slackware64.current>x/libvdpau-0.9-x86_64-1.txz]] \\   Thanks to Heinz Wiesinger.
   * [[slackware64.current>testing/source/config-testing-3.18.1/*]]   * [[slackware64.current>testing/source/config-testing-3.18.1/*]]
  
 ==== Rebuilt ==== ==== Rebuilt ====
-  * [[slackware64.current>x/xorg-server-1.15.2-x86_64-3.txz]] (Security fix)+  * [[slackware64.current>x/xorg-server-1.15.2-x86_64-3.txz]] \\   This update fixes many security issues discovered by Ilja van Sprundel, \\   a security researcher with IOActive. \\   For more information, see: \\     http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2014-8091 \\     http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2014-8092 \\     http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2014-8093 \\     http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2014-8094 \\     http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2014-8095 \\     http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2014-8096 \\     http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2014-8097 \\     http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2014-8098 \\     http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2014-8099 \\     http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2014-8100 \\     http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2014-8101 \\     http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2014-8102 \\     http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2014-8103 \\   (Security fix *)
   * [[slackware64.current>x/xorg-server-xephyr-1.15.2-x86_64-3.txz]]   * [[slackware64.current>x/xorg-server-xephyr-1.15.2-x86_64-3.txz]]
   * [[slackware64.current>x/xorg-server-xnest-1.15.2-x86_64-3.txz]]   * [[slackware64.current>x/xorg-server-xnest-1.15.2-x86_64-3.txz]]
   * [[slackware64.current>x/xorg-server-xvfb-1.15.2-x86_64-3.txz]]   * [[slackware64.current>x/xorg-server-xvfb-1.15.2-x86_64-3.txz]]
-  * [[slackware64.current>xap/MPlayer-1.1_20130819-x86_64-3.txz]]+  * [[slackware64.current>xap/MPlayer-1.1_20130819-x86_64-3.txz]] \\   Recompiled with support for libvdpau.
   * [[slackware64.current>isolinux/initrd.img]]   * [[slackware64.current>isolinux/initrd.img]]
   * [[slackware64.current>usb-and-pxe-installers/usbboot.img]]   * [[slackware64.current>usb-and-pxe-installers/usbboot.img]]
-===== ChangeLog ===== 
-<code> 
-Tue Dec 23 00:05:23 UTC 2014 
-a/kernel-generic-3.14.27-x86_64-1.txz:  Upgraded. 
-a/kernel-huge-3.14.27-x86_64-1.txz:  Upgraded. 
-a/kernel-modules-3.14.27-x86_64-1.txz:  Upgraded. 
-ap/vim-7.4.560-x86_64-1.txz:  Upgraded. 
-d/kernel-headers-3.14.27-x86-1.txz:  Upgraded. 
-k/kernel-source-3.14.27-noarch-1.txz:  Upgraded. 
-l/libusb-1.0.19-x86_64-1.txz:  Upgraded. 
-l/libusb-compat-0.1.5-x86_64-1.txz:  Upgraded. 
-n/ntp-4.2.8-x86_64-1.txz:  Upgraded. 
-  In addition to bug fixes and enhancements, this release fixes 
-  several high-severity vulnerabilities discovered by Neel Mehta 
-  and Stephen Roettger of the Google Security Team. 
-  For more information, see: 
-    https://www.kb.cert.org/vuls/id/852879 
-    http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2014-9293 
-    http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2014-9294 
-    http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2014-9295 
-    http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2014-9296 
-  (* Security fix *) 
-n/php-5.4.36-x86_64-1.txz:  Upgraded. 
-  This update fixes bugs and security issues. 
-  #68545 (NULL pointer dereference in unserialize.c). 
-  #68594 (Use after free vulnerability in unserialize()). (CVE-2014-8142) 
-  #68283 (fileinfo: out-of-bounds read in elf note headers). (CVE-2014-3710) 
-  For more information, see: 
-    http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2014-3710 
-    http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2014-8142 
-  (* Security fix *) 
-x/libdrm-2.4.58-x86_64-1.txz:  Upgraded. 
-x/libvdpau-0.9-x86_64-1.txz:  Added. 
-  Thanks to Heinz Wiesinger. 
-x/mesa-10.3.5-x86_64-1.txz:  Upgraded. 
-x/xorg-server-1.15.2-x86_64-3.txz:  Rebuilt. 
-  This update fixes many security issues discovered by Ilja van Sprundel, 
-  a security researcher with IOActive. 
-  For more information, see: 
-    http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2014-8091 
-    http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2014-8092 
-    http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2014-8093 
-    http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2014-8094 
-    http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2014-8095 
-    http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2014-8096 
-    http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2014-8097 
-    http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2014-8098 
-    http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2014-8099 
-    http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2014-8100 
-    http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2014-8101 
-    http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2014-8102 
-    http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2014-8103 
-  (* Security fix *) 
-x/xorg-server-xephyr-1.15.2-x86_64-3.txz:  Rebuilt. 
-x/xorg-server-xnest-1.15.2-x86_64-3.txz:  Rebuilt. 
-x/xorg-server-xvfb-1.15.2-x86_64-3.txz:  Rebuilt. 
-xap/MPlayer-1.1_20130819-x86_64-3.txz:  Rebuilt. 
-  Recompiled with support for libvdpau. 
-xap/vim-gvim-7.4.560-x86_64-1.txz:  Upgraded. 
-isolinux/initrd.img:  Rebuilt. 
-kernels/*:  Upgraded. 
-testing/source/config-testing-3.18.1/*:  Added. 
-usb-and-pxe-installers/usbboot.img:  Rebuilt. 
-</code> 
  
  
- +{{tag>slackware changelog slackware64-current 2014/12}}
-{{tag>news 2014/12 slackware64-current changelog}}+
  
  • news/2014/12/23/slackware64-current-changelog.txt
  • Last modified: 5 years ago
  • by Giuseppe Di Terlizzi